旧型デスクトップPCのメモリー増設~初代Core-i7機なのでメモリー選択で悩んだ

自宅でメインで使用しているPCはかなり使い続けていますが、今でも現役で動いてくれるし特に困ったことも無いので愛用しています。このPCを組んだ時はWindows XPにしておくか素直にWindows 7にするかって迷う感じでしたが(Vistaは論外)、Windows 7でもWindows 10でも特にトラブルもなく動いてくれています。オーバークロックに対応したマザーボードですがそういう興味もなく定格で使用しているのが幸いしているのかも知れません。

そんなメインPC(デスクトップ)ですが、8GBのメモリーではちょっと厳しい場面が増えてきたので16GBにすることにしました。スロットは4本あり今までは4GB✕2枚で8GBでした。大きな問題もなかったのですが動画編集やDTM(DAW)の関係でメモリーが食われることが増えてきたので4GB✕4枚にして16GB化することにしました。

ただ、このマザーボード(ASUS P7P55D-E)はメモリーを選ぶと言われていた覚えがあるので慎重になります。当時の仕様によるとやはり4GB✕4枚の16GBが最大となっているのですが、リサーチすると8GB✕4枚の32GB化にも成功したという情報があります。もはやDDR3は古いものですからヤフオクで中古で購入すれば安いものです。どうせなら8GB✕4枚にしちゃおうかなとも思いました。

しかしメモリーを選ぶマザーボードなので冒険して失敗すれば、せっかく買ったメモリーが無駄になります。32GB化する必要性に迫られているわけでも無いので無難に16GBで行くことにしました。

今まで使って来たメモリー(4GB✕2枚)に同じだけ足してやれば倍増の16GB化が可能なので無難にすすめることにしました。かと言ってかなり年数が経っているので同じものを購入するのは難しいです。したがって中古を探す事にしました。そういう場合はヤフオクですね。

追記
先入観でそう思っていましたが、まだAmazonで取り扱いがある様ですね・・

マザーボードの仕様上、PC3-1600に対応しているのですが今まで使ってきたものと同じPC3-1333にすることにしました。今更必要以上にお金をかけることもしたくありませんので無難(動いている実績あり)が一番です。

UMAX Cetus DCDDR3-8GB-1333 DIMM,4GB,DDR3-1333,256X8,CL9 1.5V

なお、ほぼ同仕様の予備PCを持っていてそちらでも同じ規格のメモリーが使用できるので使いまわしも可能にしています。お下がりをそっちに回す感じで流用しているのでパーツの無駄が出ません。


メモリーをうまく認識しない?

今まで2スロットしか使っていなかったので、空きが2スロットありました。今回4枚セットで入手したので、今まで使っていたメモリーを取り外して4枚すべてを入手したものに交換しました。

たったそれだけなのにうまく認識しない。マザーボードのMemOKランプが点滅している。ASUSのマザーボードにはMemOKというボタンがあり相性問題を解決できる可能性があるというのは購入した時から覚えています。

仕方なく今回MemOKボタンを押して認識させるのですが、BIOS上は認識しているのにPC起動中に止まってしまう・・メモリー増設以外は変更していないのに何がいけないんだ?

最後の手段でBIOSを初期化することにしました。初期値をロードすることができます。BIOSはさほどカスタマイズしていないので気にせずに初期値をロードさせたところOSは無事に起動する様になりました。

正常に認識した

初代のCore i7(1156LGA)なのでメモリーには神経質になります。

今まで使ってきたものと同じものをヤフオクで手に入れたので、もちろん無難に動作してくれました。16GB(倍)になったので快適に使えそうです。

新たな問題が発覚

OSは起動したものの増設しているHDDを全く認識してくれていません。そういえばこのマザーボードはSerial ATA 6Gb/sポートがMarvell 91xxチップで拡張されているんだった。BIOSで有効にしてみる。しかしだめ・・

これまでに何かをBIOSでいじったという記憶も無いのですが、頭を切り替えてマニュアルPDFを読みながら記憶をたどります。ディスクコントローラーとしてIDEモードとAHCIモードがありいずれかを設定するとありますが、こういう部分は気にせずに使ってきたので、このPCでWindows 7を使っていたこともありIDEモードだろうと考えました。

Marvell 91xxは概念的なことがわかりにくい。マザーボードのマニュアルに詳しいことは書いてないしMarvellのBIOS画面は見たことがないので詳細な設定は不明。数パターンに絞って設定を試行錯誤してみるしかありません。IDE/AHCIモードを適切に設定できれば認識するはず。小一時間考えながら試してようやく仕様らしきものが分かりました。

どうやらマザーボードのBIOS画面の中で勝手に起動ディスクとしてSerial ATA 6Gb/sポートに接続してあるHDDを認識してしまい、PC起動時にそれを探しに行ってフリーズしてしまっているであろうことが分かりました。明らかにOSを含んでいないHDDは起動対象外として無効にしてやるとすんなりと立ち上がる様になりました。

ただ、ここで分かったことは今までIDE/AHCIを気にせずに使って来ましたが、今はAHCIが標準となっている様なので、今どきIDEモードで使うのもどうなのかな?という気がします。やはり今どきのAHCIモードにすべきなのだろう・・・

要検討・・・調べて対応しました。

“旧型デスクトップPCのメモリー増設~初代Core-i7機なのでメモリー選択で悩んだ” への1件の返信

コメントを残す

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください